tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Дан одномерный вещественный
Дан одномерный вещественный массив b(n). найти сумму положительных элементов массива
mariii222
1 15.07.2019 06:10
0
Ответы
CatMyBoss
03.10.2020 04:37
// PascalABC.NET 3.0, сборка 1139 от 10.01.2016
begin
var n:=ReadInteger('n=');
var b:=ArrRandomReal(n,-5,10);
Writeln('Исходный массив'); b.Println(', ');
Writeln('Сумма положительных элементов ',
b.Where(x->x>0).Sum)
end.
Тестовое решение:
n= 10
Исходный массив
6.62419754156107, 6.74697848816727, 4.73433683148322, -0.587218480923781, -4.4331698163567, 0.961155824345143, -0.229649536884227, 7.50758543494511, 7.66080652720332, 9.97409514848799
Сумма положительных элементов 44.2091557961931
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
inan228
12.09.2019 05:30
Автоматическое устройство осуществило перекодировку информационного сообщения на языке, первоначально записанного в 16-битном коде unicode, в 8-битную кодировку кои-8. при этом информационное...
nadia0666p08frk
06.09.2020 14:35
Представьте результат вычисления арифметических операций в указанной СС. 506,F416 + ABC,6216...
2zeo915
07.09.2020 14:17
есть 42 строки, которые необходимо запомнить, на 1 строку требуется 5 секунд на запоминание, на следующую тратится на 2 секунды больше от сколько времени надо на запоминание 42 строк?...
Шаров2005
06.09.2020 14:52
решить информатику. В таблице приведены запросы к поисковой системе. Предоставьте результат в виле кргов эйлера по возрастанию (по количеству запросов....
Посемуська
07.09.2020 14:19
Реши задачу. (ответ округли до целых). Сколько секунд потребуется модему, передающему сообщения со скоростью 128000 бит/с, чтобы передать сообщение объёмом 276 Кбайт? ответ: сек....
Ксюша111111111111113
06.09.2020 14:28
Переведите восьмеричные числа в СС с основаниями 2, 10, 16 и обратно. a) 312,478 b) 674,358...
ket95651
07.09.2020 14:21
Что связывает между собой информационное поведение и информационную культуру?Заранее...
умник200610
06.09.2020 15:16
Ақпаратты өлшем не үшін керек нужно....
соняка2008
06.09.2020 15:55
Водолей. 8л и 5л необходимо получить 6л воды, 3 сосуда: наполни, перелей, выпей. Подскажите решение ...
odinokijcelovek
06.09.2020 15:49
С++ Входные данныеВводится натуральное число N, которое не превосходит 30.Выходные данныеВычислите 1+2+22+23+…+2 N...
Популярные вопросы
Как решить систему неравенств: 7 x^{2} -х+3 =0; 2х+3 7.(они объеденены большой...
2
Решите уравнение: 3х-5 + 2х+1 = 2х-3 7 14 2...
2
Почему произведение гроза классическое произведение ?...
1
Может ли раастояние от центра окружности до прямой равняться радиусу окружности?...
3
Распредялить слова на нейтраль. ,книжные,разговорные. смурной.печальный.скорбный.галдёж.крик.клич.глаза.мигалки.вежды.морда.лицо.лик.расхищять.красть.тибрить...
2
Два велосипедиста выехали одновременно навстречу друг другу . скорость одного...
1
Какое из слов: расстилалась, проговориться, располагаешься, прочитала. имеет схему...
1
№1 тело брошено вертикально вверх со скоростью 10 м /c на какую высоту поднимется...
3
Точки а,в,с лежат на одной прямой : ав =х , ас =х-2.может ли точка в лежать между...
3
1) ботву моркови,свеклы отрезают резким ударом ножа. почему ботва при этом легко...
1
begin
var n:=ReadInteger('n=');
var b:=ArrRandomReal(n,-5,10);
Writeln('Исходный массив'); b.Println(', ');
Writeln('Сумма положительных элементов ',
b.Where(x->x>0).Sum)
end.
Тестовое решение:
n= 10
Исходный массив
6.62419754156107, 6.74697848816727, 4.73433683148322, -0.587218480923781, -4.4331698163567, 0.961155824345143, -0.229649536884227, 7.50758543494511, 7.66080652720332, 9.97409514848799
Сумма положительных элементов 44.2091557961931