Дан массив из 40 элементов. каждый элемент может принимать целочисленные значения от 0 до 200. напишите программу, которая позволит определить, все ли элементы массива различны. программа должна вывести одно из сообщений «есть одинаковые элемены» или «все элементы различны».
var a: array [0..39] of integer; i,b: integer;
begin
randomize;
for i:=0 to 39 do a[i]:=random(0,200);
b:=1;
for i:=0 to 39 do begin
if b=39 then begin writeln('Все элементы различны'); break end
else
if (a[i]<>a[b]) and (b<39) then b+=1
else begin writeln('Есть одинаковые элемены'); break end
end
end.