дан массив из 20 элементов в интервала [5 50 ] составьте программу нахождения среднего арифметического элементов массива кратных 5 и некратных 10 (паскаль)

Traken Traken    1   21.01.2022 11:10    8

Ответы
ведим ведим  27.12.2023 02:27
Конечно, я могу помочь вам с этим заданием! Вот программа на языке паскаль для нахождения среднего арифметического элементов массива, кратных 5 и некратных 10:

```
program Average;
const
SIZE = 20; // константа, определяющая размер массива
var
arr: array [1..SIZE] of integer; // объявляем массив из 20 элементов
i, sum, count: integer; // переменные для цикла, суммы и количества элементов

begin
sum := 0; // инициализируем сумму нулем
count := 0; // инициализируем количество элементов нулем

// заполняем массив случайными числами от 5 до 50
randomize;
for i := 1 to SIZE do
begin
arr[i] := random(46) + 5; // генерируем число от 0 до 45 и прибавляем 5
writeln('Элемент ', i, ': ', arr[i]); // выводим элементы массива
end;

// вычисляем среднее арифметическое элементов, кратных 5 и некратных 10
for i := 1 to SIZE do
begin
if (arr[i] mod 5 = 0) and (arr[i] mod 10 <> 0) then
begin
sum := sum + arr[i]; // добавляем элемент к сумме
count := count + 1; // увеличиваем количество элементов
end;
end;

// выводим результат
if count > 0 then
begin
writeln('Среднее арифметическое элементов, кратных 5 и некратных 10: ', sum / count);
end
else
begin
writeln('В массиве нет элементов, кратных 5 и некратных 10');
end;

readln;
end.
```

В этой программе мы сначала объявляем массив `arr` из 20 элементов. Затем заполняем его случайными числами от 5 до 50 с помощью цикла `for`. Внутри этого цикла мы выводим каждый элемент массива на экран.

Затем мы переходим к циклу, который вычисляет среднее арифметическое элементов, кратных 5 и некратных 10. Мы используем условие `if` для проверки, является ли элемент кратным 5 и некратным 10. Если это так, то мы добавляем его к сумме и увеличиваем количество элементов.

В конце программы мы выводим результат - если количество элементов больше нуля, то выводим среднее арифметическое суммы и количества элементов, а если количество элементов равно нулю, то выводим сообщение о том, что в массиве нет элементов, удовлетворяющих условию.

Надеюсь, данное объяснение поможет вам понять программу. Если у вас возникнут дополнительные вопросы, не стесняйтесь задавать их!
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика