Дан массив из 10 элементов. составить программу, находящую среднее арифметическое положительных.

Морго11 Морго11    1   27.06.2019 20:40    10

Ответы
marina2355 marina2355  02.10.2020 13:24
Program mass;
uses crt;
var massiv:array[1..10] of integer;
     i,count:integer;
     sra:real;
begin
for i:=0 to 10 do begin
   readln(massiv[i]);
   if massiv[i] > 0 then begin
     count:= count+1;
     sra:= sra + massiv[i];
  end;
end;
sra:= sra/count;
writeln('Среднее арифметическое = ',sra);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика