Дан массив а состоящий из элементов n массив b состоящий из элементов m составить программу которая меняет порядок элементов на обратный (для ввода печати использовать функцию )в с++

Tipaniktuta Tipaniktuta    2   10.09.2019 13:40    1

Ответы
vimaa vimaa  07.10.2020 05:24
Сначала вводится N(кол-во эл-в в массиве), потом сам массив a.
Потом вводится M и массив b.
Программа выводит перевернутые массивы a и b
Если будут вопросы пиши к комментариям.

#include <bits/stdc++.h>
using namespace std;
int main(){

int N;
cin >> N;
vector<int> a(N);
for (int i = 0; i < N; i++)
    cin >> a[i];
int M;
cin >> M;
vector<int> b(M);
for (int i = 0; i < M; i++)
    cin >> b[i];
reverse(a.begin(), a.end());
reverse(b.begin(), b.end());
for (int i = 0; i < N; i++)
    cout << a[i] << ' ';
    cout << endl;
for (int i = 0; i < M; i++)
    cout << b[i] << ' ';
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика