Дан массив a[8] заполненный целыми числами от 0 до 40 .найти сумму элементов массива не превышающих 25. составить программу в poskal.заранее

premium79 premium79    1   19.07.2019 21:30    0

Ответы
играю4в4warface играю4в4warface  03.10.2020 08:15
надо хоть название языка программирования узнали.

const n = 8;
var a:array[1..n] of integer;
  s,i:integer;
begin
  //Заполнение массива значениями в диапазоне
  //от 0 до 40
  //и одновременно находим нужную сумму
  s:=0;
  for i:=1 to n do begin
    a[i]:=random(41);
    if a[i]<=25 then s:=s+a[i];
    write(a[i]:3);
  end;
  writeln;
  writeln('Сумма элементов <=25 равна ', s);
 end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика