Дан массив а(6). определите количество положительных элементов.

lera645 lera645    1   06.06.2019 03:10    1

Ответы
kotenok88 kotenok88  06.07.2020 11:42
DIM A(6)
RANDOMIZE TIMER
FOR I = 1 TO 6
    A(I) = INT(RND * 20) - 10
    IF A(I) > 0 THEN S = S + 1
    PRINT A(I); " ";
NEXT I
PRINT
PRINT "S="; S

Новый паскаль АВС
var
   a:array[1..6]of integer;
   i,s:integer;
begin
  for i:=1 to 6 do
    begin
    a[i]:=random(-10,10);
    if a[i]>0 then s:=s+1;
    write(a[i],' ')
    end;
writeln;
writeln('Количество положительных: ',s)
end.

Старый паскаль АВС
var
   a:array[1..6]of integer;
   i,s:integer;
begin
  for i:=1 to 6 do
    begin
    a[i]:=random(20)-10;
    if a[i]>0 then s:=s+1;
    write(a[i],' ')
    end;
writeln;
writeln('Количество положительных: ',s)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика