Дан двумерный массив размерностью 8х12, инициализированный целочисленными значениями из диапазона от -20 до +80. Написать программу, которая ищет минимальный четный элемент этого массива и выводит на экран его значение и его координаты.

сделать в паскале

koalakoalakoala koalakoalakoala    1   22.04.2020 23:00    3

Ответы
hadaevbogdan hadaevbogdan  13.10.2020 17:31

pascal

Объяснение:

var

 min: integer;

 i, j, k, l: integer;

 a: array[1..8,1..12] of integer;

begin

 min := 81;

 for i := 1 to 8 do begin

   for j := 1 to 12 do

     begin

      a[i, j] := random(101) - 20;

      Write(a[i, j]:4);

      if (a[i, j] < min) and (a[i, j] mod 2 = 0) then

      begin

        min := a[i, j];

        k := i;

        l := j;

      end;

     end;

   WriteLn;

  end;

  WriteLn('Минимальный четный элемент - A[',k,',',l,']=',min);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика