tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Дан целочисленный массив заданный
Дан целочисленный массив заданный датчиком случайных чисел в интервале (100). требуется умножить отрицательные значения элементов этого массива на 20.
AnnaMax111
1 13.09.2019 05:40
2
Ответы
nshexovceva18
07.10.2020 11:23
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-100,100); a.Println;
a.Transform(t->t<0?t*20:t); a.Println
end.
Пример
n= 13
-82 6 99 -23 71 -92 50 -70 -82 37 -10 -97 92
-1640 6 99 -460 71 -1840 50 -1400 -1640 37 -200 -1940 92
ПОКАЗАТЬ ОТВЕТЫ
nastaklimenkofll
07.10.2020 11:23
//Код с комментариями во вложении
//Pascal
var
A: array [1..20] of integer;
i: byte;
begin
randomize;
for i := 1 to 20 do
begin
A[i] := random(201)-100;
if A[i] < 0 then A[i] := A[i] * 20;
write(A[i], ' ');
end;
writeln;
readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
pawskayaliolya
30.04.2021 12:43
СОР Информатика надо, а то мне сикир бошка тюк тюк поварежка...
лина28051
30.04.2021 12:43
1.Не себепті технологиялар дамып жатыр ?...
Анна666111
20.08.2019 20:30
Какие размеры могут иметь материальные модели от чего это зависит...
SokolDev
21.10.2019 21:00
Язык программирования python. напишите программу, которая принимает данные от пользователя с функции input и печатает результат в консоль. ввод данных пользователь...
baubaubau
23.04.2020 13:55
Написать программы для решения задач ( задачи под знаками ? )...
yli4ka2007
22.08.2019 21:00
Земляничке подарили 36 фантиков от карамелек,что на 22 меньше чем от шоколадных конфет.сколько всего фантиков от карамелек и шоколадных конфет подарили земляничке....
Брежний
22.08.2019 21:00
Скраткой записью! масса ящика 4кг, а картофель в ящике в 8 раз тяжелее. какова масса ящика с картофелем?...
silverking
22.08.2019 21:00
(a-6)(a+6)+(3-a)(3+a) спростити вираз будь ласочка...
Лена2222
22.08.2019 21:00
Написать сочинение: как появились союзы 50 ....
Владивостокер
22.08.2019 21:00
Просклоняйте числительные: -двадцатый -двухсотый -двухтысячный...
Популярные вопросы
Вычислите наибольшее и наименьшее значение выражения 3-4sin2t при...
1
Почему нельзя считать ядро обязательным компонентом клеток организмов?...
1
Сколько было лет мальчикам из расказа бежин луг ?...
2
Решите уравнения: 1) корень х = 7 2) корень х-8 =0 3)2 корень х-3...
1
Определи склонение и падеж всех существительных события недели в...
1
Морфологический разбор решенная ( )...
1
Расскажите о няне пушкина,какое влияние она оказала на писателя?...
2
Решите пропорцию: а) х/9 = 10/3 б)11/42=х/63...
3
1) 275× 32+ 725×28+ 275× 18+ 725× 22 2)326× 67+ 174× 29+ 326× 33+...
1
Спиши текст.подчеркните определение и в скобках напишите вопрос,на...
3
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-100,100); a.Println;
a.Transform(t->t<0?t*20:t); a.Println
end.
Пример
n= 13
-82 6 99 -23 71 -92 50 -70 -82 37 -10 -97 92
-1640 6 99 -460 71 -1840 50 -1400 -1640 37 -200 -1940 92
//Pascal
var
A: array [1..20] of integer;
i: byte;
begin
randomize;
for i := 1 to 20 do
begin
A[i] := random(201)-100;
if A[i] < 0 then A[i] := A[i] * 20;
write(A[i], ' ');
end;
writeln;
readln;
end.