Дан целочисленный массив размера n, заполненный целыми числами не превышающими 104. необходимо получить два новых массива: в первом массиве должны быть собраны только четные числа, а во втором - нечетные числа. порядок следования элементов в новых массивах не нарушать. формат ввода в первой строке входного файла записано целое число n - размер массива (1 ⩽ n ⩽ 1000). во второй строке записано n целых чисел через пробел, не превышающих 104. формат вывода

gremorixiii gremorixiii    3   18.08.2019 18:20    6

Ответы
хочузнать2018 хочузнать2018  08.09.2020 19:20
// PascalABC.NET 3.2, сборка 1374 от 10.01.2017
// Внимание! Если программа не работает, обновите версию!

procedure PrintArr(f:Text; a:array of integer);
begin
  foreach var x in a do Write(f,x,' ');
  Writeln(f)
end;

begin
  var fin:=OpenRead('input.txt');
  var n:=ReadlnInteger(fin);
  var a:=new integer[n];
  for var i:=0 to n-1 do Read(fin,a[i]);
  var fout:=OpenWrite('output.txt');
  fin.Close;
  PrintArr(fout,a);
  var b:=a.Where(x->x.IsEven).ToArray;
  PrintArr(fout,b);
  var c:=a.Where(x->x.IsOdd).ToArray;
  PrintArr(fout,c);
  fout.Close
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика