tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Дан целочисленный массив
Дан целочисленный массив на n элементов вывести на экран элементы, которые меньше или равны своему номеру. заранее
justnero
1 26.07.2019 18:40
0
Ответы
kira757
30.08.2020 23:28
Const n=15;
var a:array[1..n] of integer;
i:integer;
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
begin
a[i]:=random(16);
write(a[i]:3);
end;
writeln;
for i:=1 to n do
if a[i]<=i then write(a[i]:3) else write(' ':3);
writeln;
end.
Пример:
Массив A:
14 8 14 1 6 2 4 7 10 3 4 6 15 14 2
1 2 4 7 3 4 6 14 2
ПОКАЗАТЬ ОТВЕТЫ
lavira3
30.08.2020 23:28
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
var a:=ArrRandom(ReadInteger('n='),-20,20);
a.Println;
a.Where((x,i)->x<=i+1).Println
end.
Тестовое решение:
n= 15
-16 7 -17 -9 6 3 2 20 -15 7 -10 10 -6 -19 1
-16 -17 -9 3 2 -15 7 -10 10 -6 -19 1
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
ЮляЯяя1111
05.09.2019 15:00
Переведите 1048576 бит в килобайты...
pdv20
05.09.2019 15:00
Какими графическими образами можно проиллюстрировать 1) виды информации; 2) свойства информации....
noname1372321
05.09.2019 15:00
Пример известных вам носителей информации...
даша3648
18.07.2019 08:20
F=pgv написать программу, где p - плотность, g - ускорение свободного падения g: =10, v-объем....
chobanu81p08xbb
01.08.2019 20:30
Стоят три кувшина,в одном кувшине 8 литров,в другом 5 литров,а в третьем 3 литра.в первом кувшине(это ток в котором 8 л.) 8 литров воды .как в кувшин в котором 5 литров...
mamutova0303
21.11.2020 22:41
Пригадайте бо знайдіть в інтернеті назви планет сонячної системи створіть список автозаповнення з назвами планет...
oforange
21.11.2020 22:37
Параллелепипед бетінің көлемі мен ауданын есептейтін процедура жазыңдар...
Matthieu5401
21.11.2020 22:34
Android dasturlash uchun qaysi dasturlash tili qulay va oson?Va nima uchun?...
nastya010620163535
21.11.2020 22:33
С клавиатуры вводится строка состоящая из предложений разделяемых точками.Составьте программу выполняющую следующие форматирования:первое слово в предложении должно...
slaviktaran00
21.11.2020 22:32
С клавиатуры вводится строка содержащая предложение или несколько коротких предложений.Составьте программу которая каждый пробел заменяет символом визуализации пробела(•)...
Популярные вопросы
Речовини, з якими реагує карбон(ІV) оксид: А вода й кальцій оксид;...
3
2.Географияда кеңінен қолданылатын модельдеу түрлері қандай? 3.Ғылым...
3
Итог испанской колониальной империи....
1
Знайдіть урожайність (у ц/га) пшениці якщо з ділянки прямокутної...
3
Ақыретте біреудің қанын жүктеп барып тәңірі алдында қарабет болмасын,...
3
Скласти план Калина, М. Фомін. Калина. ...
1
Представь проценты в виде десятичной дроби 40%=?...
3
В тетради решите неравенства, используя алгоритм АЛГЕБРА 9 КЛАСС...
1
обчисли об єм циліндричної посудини, висота якої дорівнює 40 см,...
1
(3с-2)(3с+2)(9с²+4)-(9с²-4)²...
1
var a:array[1..n] of integer;
i:integer;
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
begin
a[i]:=random(16);
write(a[i]:3);
end;
writeln;
for i:=1 to n do
if a[i]<=i then write(a[i]:3) else write(' ':3);
writeln;
end.
Пример:
Массив A:
14 8 14 1 6 2 4 7 10 3 4 6 15 14 2
1 2 4 7 3 4 6 14 2
begin
var a:=ArrRandom(ReadInteger('n='),-20,20);
a.Println;
a.Where((x,i)->x<=i+1).Println
end.
Тестовое решение:
n= 15
-16 7 -17 -9 6 3 2 20 -15 7 -10 10 -6 -19 1
-16 -17 -9 3 2 -15 7 -10 10 -6 -19 1