Дан целочисленный массив из 70 элементов.элементы массива могут принимать целые значения от 0 до 100.составить программу ,позволяющую найти и вывести элементы массива, которые не кратны 9 и находятся в диапазоне[30,70].гарантируется,что в исходном массиве есть хотя бы один такой элемент.

111dashamm639 111dashamm639    1   03.06.2019 11:40    2

Ответы
Wjdjsjsksji Wjdjsjsksji  01.10.2020 18:20
Const
    auto = true;
    n = 70;

var
    a: array[1..n] of integer;
    i: integer;

begin
    for i := 1 to n do
    begin
        if auto then
            a[i] := random(100)
        else readln(a[i]);
       
        if (a[i] <= 70) and (a[i] >= 30) and (a[i] mod 9 > 0) then
            writeln(a[i]);
    end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика