Дан целочисленный массив из 50 элементов. элементы массива могут принимать значения от –500 до 500. напишите программу, которая находит и выводит среднее арифметическое всех элементов массива, оканчивающихся цифрой 3 плз

kolafeoktistovp0aj9j kolafeoktistovp0aj9j    3   10.09.2019 15:10    0

Ответы
Sahsa65432 Sahsa65432  16.08.2020 13:28
PascalABC.NET:

begin
  var a:=ArrRandom(50,-500,500);
  a.Println;
  var k:=a.Where(x->(abs(x) mod 10 = 3)).Count;
  var s:=a.Where(x->(abs(x) mod 10 = 3)).Sum;
  if k=0 then writeln('В массиве нет элементов, оканчивающихся цифрой 3')
  else Writeln('Среднее арифметическое элементов массива, оканчивающихся цифрой 3 = ',s/k);
end.

Пример (для 10 элементов):
450 -159 189 463 262 220 -125 -41 -178 -62
Среднее арифметическое элементов массива, оканчивающихся цифрой 3 = 463
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика