Дан целочисленный массив из 20 элементов. элементы массива принимают значения от 0 до 10000 включительно. написать программу, позволяющую найти и вывести максимальное значение среди трехзначных элементов массива, делящихся на 4. если в исходном массиве нет трехзначного элемента, который делится на 4, то вывести сообщение о том, что такого числа нет.

lunova0921 lunova0921    1   03.06.2019 21:30    3

Ответы
vlad09101986 vlad09101986  05.07.2020 01:54
Var
  max, i : integer;
  a : array [1..20] of integer;
begin
  max := -1;
  for i := 1 to 20 do read (a[i]);
  for i := 1 to 20 do
    if (a[i] < 1000) and (a[i] > 99) and (a[i] mod 4 = 0) and (a[i] > max) then
      max := a[i];
  if max > -1 then write (max) else write ('Nety');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика