tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Дан целочисленный массив d
Дан целочисленный массив d из 16 элементов, найти сумму первых восьми элементов массива и произведение оставшихся восьми элементов
ПОМОГИТЕУМОЛЯЮЯТУПОЙ
3 07.06.2019 20:50
0
Ответы
Dima1Tap
07.07.2020 11:35
Const n:=16;
var
d:array[1..n] of integer;
i,a,c:integer;
begin
a:=0;
c:=1;
for i:=1 to n do
readln(d[i]);
for i:=1 to 8 do
a:=a+d[i];
for i:=9 to 16 do
c:=c*d[i];
writeln(a);
writeln(c);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
tata20082
15.07.2019 23:40
Назовите и охарактеризуйте элементы текста...
tikatS66
15.07.2019 23:40
Спортсмен в первый день пробежал 10 км. каждый следующий день он увеличивал дневную норму на 10% от результата предыдущего дня. найти,через сколько дней спортсмен будет пробегать...
kokocuk01
15.07.2019 23:40
Дано число. определить сумму цифр в этом числе....
adamenkofamily
30.10.2021 22:49
Программы 24 Создание папки на рабочем столе 1) осуществляется с команды Главное мен Создать Папку 2) выполняется с команды Пуск Создать Папку 3) выполняется из контекстного...
милаш06
30.10.2021 22:56
Напишите программу, которая вводит два целых числа и находит их произведение, пока произведение будет трехзначное число....
alexsey13
03.04.2020 06:42
Using UnityEngine; using System.Collections; public class PlayerMoment : MonoBehaviour { public float speed: Rigidbody rb: void Start () { rb = GetComponent (): } void Update...
Ketrin2316
20.05.2021 16:30
ПРИВЕТ, МОЖЕШЬ РЕШИТЬ ЗАДАЧУ Python (ПИТОН) БУДУ ОЧЕНЬ БЛОГАДАРЕН.ЭТО НАДО ДЕЛАТЬ ПРЯМ В ПИТОНЕ.УДАЧИ. ...
lisa301
20.05.2021 16:32
Написать программу: Дана строка. Подсчитать сколько слов в строке.Строка оканчивается точкой.Вводится фраза на русском языке. Регистр букв различен.Привести к нормальному формату:...
thesexyone72
09.08.2019 02:30
Написать в тетради все устройства компьютера(не системного блока). определение системного блока,устройство ввода....
итлиори
09.06.2019 13:30
Втреугольнике abc проведена медиана am,равная половине стороны bc. найдите периметр треугольника amc,если ab=3 см и периметр треугольника abc=12 см...
Популярные вопросы
Исследуйте функцию с производной и постройте её график. Задание 152 функции...
1
Кем хотел быть Майсалбек до войны...
2
Кумға не Барханға өз атыңнан хат жаз немесе құмның атынан Барханға хат жаз....
1
Решить уравнением и по действиям. Кофейные зёрна при жарке теряют 12,5% своей...
1
Упражнение 2. Дополните предложения правильным модальным глаголом. Используйте...
1
Тема для рефератов,сообщений,сочинений. - снегурочка и устное народное творчество...
1
Тема: расскажите о деле которое объединило вас с вашими друзьями10 предложенийплан:1....
3
сделать письменный морфо разбор числительного пять курей,десять часов на украинском...
1
Минут пять в обоюдном молчании, (в) продолжени_ которого незнакомец курил...
3
Колобома – дефект оболонки очей – успадковується за аутосомно-домінантним...
1
var
d:array[1..n] of integer;
i,a,c:integer;
begin
a:=0;
c:=1;
for i:=1 to n do
readln(d[i]);
for i:=1 to 8 do
a:=a+d[i];
for i:=9 to 16 do
c:=c*d[i];
writeln(a);
writeln(c);
end.