Дан целочисленный двумерный массив 6x10. опишите на языке и на языке программирования паскаль алгоритм вычисления произведения минимальных элементов из каждой строки. напечатать значение этого произведения. предполагается, что в каждой строке минимальный элемент единственный.

onyfriyevanast onyfriyevanast    3   30.05.2019 08:20    1

Ответы
stovhelen stovhelen  30.06.2020 08:04
Ну в общих чертах проходиться по каждой строке массива, находить минимальный элемент и на него домножать результат.

uses crt;
const n=6;m=10;
var i,j,min,ans:integer;
a:array[1..n,1..m] of integer;
begin
ans:=1;
for i:=1 to n do
begin
for j:=1 to m do
begin
a[i,j]:=random(1,20);
write(a[i,j]:3);
end;
writeln;
end;
for i:=1 to n do
begin
min:=a[i,1];
for j:=2 to m do
if a[i,j]<min then
min:=a[i,j];
ans:=ans*min;
end;
writeln(ans);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика