Clrscr; 30 б составить программу на языке паскаль,возведения числа х в степень числа y.

annelya009 annelya009    2   28.09.2019 04:40    0

Ответы
cherdancev05Gleb cherdancev05Gleb  21.08.2020 17:18

var

   x, y, result:real;

begin

   readln(x, y);

   result := 1;

   if y > 0 then

   begin

       while y <> 0 do

       begin

           result := result * x;

           y := y - 1;

       end;

   end

   else if y < 0 then

   begin

       while y <> 0 do

       begin

           result := result * x;

           y := y + 1;

       end;

       result := 1 / result;

   end

   else result := 1;

       

   writeln('x^y = ', result);


end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика