Cи написать программу, считывающую с клавиатуры 32-битное беззнаковое число n, числа a и b и выводящую на экран число, равное исходному n, но с установленным битом номер a и снятым битом номер b

юлия1764 юлия1764    1   19.06.2019 19:30    0

Ответы
VerochkaL86V VerochkaL86V  02.10.2020 05:36
#include <iostream>
using namespace std;

int main() {
    unsigned int n,a,b;
    cin>>n>>a>>b;
    n&=1<<a;
    n&=(0x)-(1<<b);
    cout<<n;
    return 0;
}
Что-то в этом духе
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика