Чуваки, . не шарю совсем, надо написать программу и лучше с объяснениями. дано натуральное число. верно ли, что в данном числе нет данной цифры а (цифру а вводить с клавиатуры)

AyHaN123 AyHaN123    1   09.08.2019 14:00    3

Ответы
yyyye yyyye  09.08.2020 07:51
Требуемая программа:
var n,a: longint; b: boolean;
begin
readln(n);
readln(a);
b:=false;
while n>0 do
 begin
 if n mod 10 = a then b:=true;
 n:=n div 10;
 end;
if b 
 then writeln('В числе есть введенная цифра')
 else writeln('В числе нет введенной цифры');
end.

Пример:
1236548
2
В числе есть введенная цифра
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика