Чему равно значение функции F(99)+F(100)? Pascal


Чему равно значение функции F(99)+F(100)? Pascal

fatimo4kkkka fatimo4kkkka    2   06.12.2020 11:12    4

Ответы
ариана54091 ариана54091  05.01.2021 11:18

107875178

Пример решения на языке PascalABC.NET:

function F (n:real):real;

begin

 if n <=5 then result:=n*2 else

 if (n>5) and (Frac(n/2) = 0) then result:=(F(n-2)+3*F(n/2)) else

 if (n>5) and (Frac(n/2) <> 0) then result:=(F(n-1)+F(n-2)+F(n-3));

end;

begin

 var D:=F(99)+F(100);

 writeln('Результат вычислений: ',D);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика