C++ #include Написать программу, которая позволяет игроку выбрать (купить)
персонажа и оружие, после чего показывает его выбор и состояние
кошелька. Изначально на счету игрока – 1000 монет. Предусмотреть
обработку ошибок ввода и возможную нехватку средств.
#include <iostream>
#include <limits>
int main() {
// Инициализация начальных значений
int playerCoins = 1000;
std::string character;
std::string weapon;
// Вывод доступных персонажей и оружия
std::cout << "Доступные персонажи: A, B, C" << std::endl;
std::cout << "Доступное оружие: X, Y, Z" << std::endl;
// Выбор персонажа
std::cout << "Выберите персонажа (A, B, C): ";
std::cin >> character;
// Проверка на ошибку ввода
if (character != "A" && character != "B" && character != "C") {
std::cout << "Ошибка ввода. Выбран недопустимый персонаж." << std::endl;
return 1;
}
// Выбор оружия
std::cout << "Выберите оружие (X, Y, Z): ";
std::cin >> weapon;
// Проверка на ошибку ввода
if (weapon != "X" && weapon != "Y" && weapon != "Z") {
std::cout << "Ошибка ввода. Выбрано недопустимое оружие." << std::endl;
return 1;
}
// Проверка на доступность средств
int characterCost = 500;
int weaponCost = 300;
if (playerCoins < characterCost || playerCoins < weaponCost) {
std::cout << "Нехватка средств." << std::endl;
return 1;
}
// Вычитание стоимости из кошелька игрока
playerCoins -= characterCost;
playerCoins -= weaponCost;
// Вывод выбора игрока и состояния кошелька
std::cout << "Выбранный персонаж: " << character << std::endl;
std::cout << "Выбранное оружие: " << weapon << std::endl;
std::cout << "Остаток на счете: " << playerCoins << " монет" << std::endl;
return 0;
}