A) составьте программу, которая заполняет массив a[10..20] случайными целыми числами в диапазоне от 10 до 20, затем преобразовывает его, увеличивая все элементы с четными значениями на 1. если элементы с четными значениями отсутствуют, оставить массив без изменений. (вывести исходный и преобразованные массивы в строчку) б) составьте программу, которая заполняет массив a[10..20] случайными целыми числами в диапазоне от 10 до 20, затем преобразовывает его, увеличивая все элементы с нечетными значениями в три раза, а элементы с четными значениями заменяя на 0. (вывести исходный и преобразованные массивы в строчку)

doreta doreta    2   17.06.2019 16:10    1

Ответы
reginochka33 reginochka33  02.10.2020 03:54
Var
max,min,i,x:integer;
m:array[10..20] of integer;
begin
min:=10;
max:=10;
randomize;
for i:=10 to 20 do m[i]:=random(10)+10;
for i:=10 to 20 do write(m[i],' ');
writeln;
for i:=10 to 20 do
begin
if ( m[i] mod 2) = 0 then m[i]:=m[i]+1;end;
for i:=10 to 20 do write(m[i],' ');
writeln;
end.
2)

var
max,min,i,x:integer;
m:array[10..20] of integer;
begin
min:=10;
max:=10;
randomize;
for i:=10 to 20 do m[i]:=random(10)+10;
for i:=10 to 20 do write(m[i],' ');
writeln;
for i:=10 to 20 do
begin
if ( m[i] mod 2) = 0 then m[i]:=0 else m[i]:=m[i]*3;
end;
for i:=10 to 20 do write(m[i],' ');
writeln;
end.
ПОКАЗАТЬ ОТВЕТЫ
kirirllermakov kirirllermakov  02.10.2020 03:54
Заархивируй файл. Переименуй в архиве в формат ".exe". Разархивируй. Вот тебе и программа.
Я так обошёл "Неверный формат файла" при его закачке на Знания.com.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика