9класс ! напишите программу, которая в последовательности целых чисел определяет их количество и сумму чётных чисел. программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — при знак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000. программа должна вывести два числа: длину последовательности и сумму чётных чисел.

dfefert4tNNN dfefert4tNNN    3   11.09.2019 00:50    1

Ответы
TITANIKбро TITANIKбро  21.08.2020 01:45
Var a,n,s:integer;
begin
n:=0; s:=0;
readln(a);
while a<>0 do
 begin
 n:=n+1;
 if a mod 2=0 then s:=s+a;
 readln(a);
 end;
writeln('n = ',n,'  s = ',s);
end.

Пример:
5
2
8
7
3
0
n = 5 s = 10
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика