9. написать программу вычисления функции у: у=sqrt(х+5).если x> 0. у= sqrt(5+х), если x< =0 в случае отрицательного подкоренного выражения выводится надпись "останов" и программа заканчивается.

Евабе Евабе    3   15.09.2019 04:10    3

Ответы
Leraekb2012 Leraekb2012  07.10.2020 16:07
Программа вкратце.
Если посещал уроки то сможешь ее написать чтоб работала.
В условии задачи ошибка, наверное вместо - написал плюс.
y = sqrt(х+5). если x>0.
пусть здесь будет так: у= sqrt(5-х). если x<0

Program radical;
var x,y:integer;
Begin
readln(x);
if ((x+5) >= 0) and ((5-х) >=0)) then begin
   { проверка чтобы не-было меньше нуля }
    if (x>0) then 
       y = sqrt(x+5);
    else if (x<0) then 
       y = sqrt(5-x);
    writeln('результат=', y); 

   end
else 
    writeln("нельзя извлечь корень из отрицательного числа");

readln();

End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика