5.Программа получает на вход натуральное число N (1 ≤ N ≤100). Выведите на экран таблицу размером NxN, заполненную по следующему правилу: по краям таблицы стоят 0, а в середине X. Язык Питон

alex010203 alex010203    2   18.05.2020 21:11    20

Ответы
1qq 1qq  14.10.2020 23:19

n = int(input())

a = [['0'] * n for i in range(n)]

for i in range(1, n-1):

    for j in range (1, n-1):

         a[i][j] = 'X'

for l in a:

    print(*l)

Объяснение:

Сначала программа получает число, и создает двумерный массив NxN, заполненный нулями. Затем идет цикл, который заполняет иксами все, кроме боковых сторон

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика