40 ! сделать паскаль 1.составьте программу, которая вычисляет сумму всех нечетных, двузначных чисел; 2.дано натуральное число n. вычислите n5; 3.дано число n. напечатать натуральные числа, квадрат которых не превышает n.

Санёк1616 Санёк1616    1   10.09.2019 22:10    2

Ответы
gopkomaks gopkomaks  03.08.2020 23:59
1.
var s,i:integer;
begin
s:=0;
for i:=10 to 99 do
 if i mod 2=1 then s:=s+i;
writeln('s = ',s);
end.

Результат:
s = 2475

2. Без использования стандартных функций:
var n,p,i:integer;
begin
readln(n);
p:=1;
for i:=1 to 5 do p:=p*n;
writeln(n,'^5 = ',p);
end.

Пример:
2
2^5 = 32

3.
var n,i:integer;
begin
readln(n);
i:=1;
while i*i<n do
 begin
 writeln(i,' (',i,'^2 = ',i*i,')');
 i:=i+1;
 end;
end.

Пример:
30
1 (1^2 = 1)
2 (2^2 = 4)
3 (3^2 = 9)
4 (4^2 = 16)
5 (5^2 = 25)
ПОКАЗАТЬ ОТВЕТЫ
СашкаО СашкаО  03.08.2020 23:59
1)
var
  i: byte;
  sum: integer;
begin
  sum := 0;
  i := 11;
  while i < 100 do
  begin
    sum := sum + i;
    i := i + 2;
  end; 
  writeln('Сумма нечетных элементов = ', sum);
  readln;
end.

2)
var
  n: real;
begin
  write('Введите n: ');
  readln(n);
  n := exp(ln(n) * 5);
  writeln(n);
  readln;
end.

3)
var
  n: integer;
  i: integer;
begin
  write('Введите n: ');
  readln(n);
  i := 0;
  for i := 1 to n do
    if sqr(i) <= n then
      write(i, ' ')
    else
      break;
  readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика