35 написать программу на языке программирования в паскале: найти все целые числа из промежутка от 100 до 300, у которых сумма делителей равна k? (k вводится с клавиатуры)​

Elizabet4722 Elizabet4722    1   30.03.2019 15:23    0

Ответы
r27121983 r27121983  27.05.2020 18:08

var i,k,j,s:integer;

begin

  readln(k);

  FOR I:=100 TO 300 DO

  begin

     s:=0;

     for j:=1 to i do

     if i mod j=0 then s:=s+j;

     if s=k then writeln(i);

 end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика