30 напишите программу, которая в последовательности натуральных чисел определяет количество самых больших чисел в последовательности. программа получает на вход количество чисел в последовательности, а затем сами числа. количество чисел не превышает 100 введённые числа по модулю не превышают 300 программа должна вывести одно число: количество самых больших чисел в последовательности. пример работы программы: входные данные 5 выходные данные 2 15 27 24 12 27
Pascal:
var a,n,count,max,i:integer;
begin
count :=0;
max:= -1;
readln(n);
for i:=1 to n do
begin
readln(a);
if (a>max) then
begin
max:=a;
count:=1;
end
else
begin
if (a = max) then
count:=count+1;
end
end;
writeln(count);
end.