3. Написать программу, которая сначала обеспечит ввод 10 чисел в одномерный массив, затем вычислит: а) сумму положительных элементов
б) сумму нечетных элементов
в) сумму чётных положительных элементов
г) количество отрицательных элементов
Язык PASCAL.

Sosushka Sosushka    1   16.12.2020 23:53    0

Ответы
ZiGZaG4242 ZiGZaG4242  12.02.2021 20:31

var a:array[1..10] of integer;

i,q,w,e,r:integer;

begin

q:=0;

w:=0;

e:=0;

r:=0;

for i:=1 to 10 do

Begin

Write('Введите значение: ');

readln(a[i]);

if a[i]>0 then q:=q+a[i];

if a[i] mod 2 <> 0 then w:=w+a[i];

if (a[i] mod 2 = 0) and (a[i]>0) then e:=e+a[i];

if a[i]<0 then r:=r+1;

end;

WriteLn('Сумма положительных элементов: ', q);

WriteLn('Сумма нечетных элементов: ', w);

WriteLn('Сумму чётных положительных элементов: ', e);

WriteLn('Количество отрицательных элементов: ', r);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика