tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
2. в массиве а: 7, 0,
2. в массиве а: 7, 0, -2, 0, 3 все нулевые элементы заменить их индексами. вывести на экран новый массив.
aynurwuk
2 23.07.2019 06:30
0
Ответы
konoplya88
23.09.2020 21:56
Const n = 5;
var a:array[1..5] of integer;
i:integer;
begin
a[1]:=7; a[2]:=0; a[3]:=-2;
a[4]:=0; a[5]:=3;
for i:=1 to n do if a[i]=0 then a[i]:=i;
for i:=1 to n do write(a[i]:3);
end.
Тестовое решение:
7 2 -2 4 3
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
irynks468dig
15.07.2019 00:30
Водном тесте пишет: превышено максимальное время . : вывести все простые числа от m до n включительно. входные данные в первой строке находятся разделённые пробелом m и n. 2 = m =...
gulmagomedova1p01bx7
15.07.2019 00:30
После копирования ячейки а2 в ячейки в2 и а3 в них были занесены формулы =$a1+c1 и =$a2+b2 соответственно. что было записано в ячейке а2?...
IncolaRO
15.07.2019 00:20
Почему программа(паскаль) не выполняет первое условие if? program tn; var a: integer; begin writeln ( введи число ); read(a); if ((a =1000)and (a 100))then writeln ( ошибка ); if...
GucciGang007
20.12.2019 11:41
Ск/р по информатике! 2 варианта ; ) всего 2 по паскалю!...
Счacтье2005
20.12.2019 11:42
Создать циклическую блок-схему. : дано натуральное число n. определить, равна ли первая цифра числа последней цифре числа (строковые функции не использовать)....
tjumentseva20031
20.12.2019 11:50
D) совокупность информации по определённой теме 3. блок образован ячейками с3, c4, c5, с6. его адрес а) с3-c6 b) c3: 06 c) (c3 c6) d) от с3 до с6 ! я на тесте...
Kristina122205
21.04.2021 21:54
Дано несколько чисел. Вычислите их сумму. Сначала вводите количество N, затем вводится ровно N целых чисел. Язык программирования- Паскаль....
replinova
21.04.2021 21:54
Напишите программу с функций def, которая рисует три квадрата разных цветов, как на этом изображении (размер «квадрата»неважен, только форма и любые три разных цвета)...
Artemvmmv
21.04.2021 21:52
Задано натуральное n. найти произведение чисел , кратных 7 от 1 до n. ...
vladgubin78
21.04.2021 21:49
PASCAL ABC Дана строка, содержащая из заглавных английских букв.Определить количество повторений каждой буквы в строке.Пример входного файлаDYQYKJQUKПример выходного файлаD-1J-1К-2Q-2U-1Ү-2...
Популярные вопросы
He is a good doctor. нужно задать 5 вопросов к предложению....
3
Проверьте постановку знаков, причастные обороты. маму моего папы зовут бабушкой...
2
Спільнокореневі слова до слова малювати...
2
Какой объём водорода нужен для полного взаимодействия с 2 моль углерода, если в...
2
Напишите уравнения реакций,с которых можно осуществить следующие превращения: so3-...
1
Змололи 3т600кг пшениці. борошно становило чотири п ятих пшениці,манних крупів...
1
Что двигает заряженные частицы в синхрофазотроне?...
2
Постойте график функции у=2х- координаты точки пересечения этого графика с прямой...
1
Политика слишком серьезное дело, чтобы ей занимались одни политики...
1
Вставить пропущенные буквы,раскрыть скобки и вставить два знака препинания многие...
3
var a:array[1..5] of integer;
i:integer;
begin
a[1]:=7; a[2]:=0; a[3]:=-2;
a[4]:=0; a[5]:=3;
for i:=1 to n do if a[i]=0 then a[i]:=i;
for i:=1 to n do write(a[i]:3);
end.
Тестовое решение:
7 2 -2 4 3