2. составьте программу для нахождения количества литров l, которое содержится в x галлонах (1 галлон = 4,54609 литра). исходное количество галлонов задается с клавиатуры. 3. напишите программу вычисления общего члена bn и суммы sn первых n членов прогрессии. первый член прогрессии b1, знаменатель прогрессии q и число членов с клавиатуры.

tanyamonter tanyamonter    1   21.08.2019 12:50    17

Ответы
TookteR TookteR  05.10.2020 09:18
//PascalABC.NET 3.2 сборка 1318

Const
  gal=4,54609;

  Var
  x:real;
begin
readln(x);
writeln(x*gal);
end.

//2

Var
  b1,q:real;
  n:integer;
begin
readln(b1,q,n);
if (b1=0) or (q=0) then
  begin
    writeln('b1=0 or q=0');
    exit;
  end
else
if q=1 then
   begin
    writeln('Sum=',b1*n);
    writeln('Bn=',b1);
  end
 else
 begin
  Writeln('Sum=',b1*(1-power(q,n))/(1-q));
  Writeln('Bn=',b1*power(q,n-1));
 end;
 end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика