2) написать программу вычисления площади треугольника, если известны длины двух сторон и величина угла между этими сторонами. ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом). вычисление площади треугольника. введите (через пробел) длины двух сторон (см) треугольника = 25 17 введите величину угла между сторонами треугольника = 30 площадь треугольника: 106.25 кв.см.

2525008 2525008    3   09.06.2019 03:40    9

Ответы
beelan3 beelan3  01.10.2020 22:49
Var
  a,b,alpha,s:real;
begin
  writeln('Вычисление площади треугольника');
  writeln('Введите (через пробел) длины двух сторон (см) треугольника');
  readln(a,b);
  writeln('Введите величину угла (градус) между сторонами треугольника');
  readln(alpha);
  alpha:=DegToRad(alpha);
  writeln('Площадь треугольника: ',0.5*a*b*sin(alpha),' кв.см.')
end.

Тестовое решение:

Вычисление площади треугольника
Введите (через пробел) длины двух сторон (см) треугольника
25 17
Введите величину угла (градус) между сторонами треугольника
30
Площадь треугольника: 106.25 кв.см.

Вычисление площади треугольника
Введите (через пробел) длины двух сторон (см) треугольника
11 16.3
Введите величину угла (градус) между сторонами треугольника
39
Площадь треугольника: 56.4185730576179 кв.см.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика