100 ! ! напишите программу в python 2.7 или 3.3 по данному числу n выведите все целые степени двойки, не превосходящие n, в порядке возрастания. операцией возведения в степень пользоваться нельзя! входные данные: вводится натуральное число выходные данные: выведите ответ на пример входные данные: 50 выходные данные: 1 2 4 8 16 32

qqwqe qqwqe    3   14.08.2019 11:10    5

Ответы
али421 али421  04.10.2020 18:31
Var n,st:integer; begin write('n = '); readln(n); st:=1; while st<=n do begin write(st,' '); st:=st*2; end; writeln; end. Пример: n = 50 1 2 4 8 16 32
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика