10 класс напишите программу, которая сначала считывает натуральное число, а затем печатает значение наибольшей из цифр в его записи в системе счисления с основание 4. исходное число не превышает 10000. заранее !
Var i,k,m,a:integer; begin write('n: '); readln(a); m:=0; for i:=0 to 6 do begin k:=(a shr (2*i))and 3; if k>m then m:=k end; writeln('Max 4-ciffer is ', m); readln end.
begin
write('n: '); readln(a); m:=0;
for i:=0 to 6 do begin k:=(a shr (2*i))and 3; if k>m then m:=k end;
writeln('Max 4-ciffer is ', m); readln
end.