tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
1. задан массив d. определить
1. задан массив d. определить следующие суммы: d[1] + d[2] + d[3]; d[3] +d[4] +d[5]; d[4] + d[5] + d[6], используя подпрограмму для вычисления суммы трех последовательно расположенных элементов массива.
EvgeniaDymova
1 17.07.2019 22:20
12
Ответы
ssnz344
03.10.2020 06:40
#include <iostream>
#include <sstream>
#include <fstream>
#include <string>
#include <vector>
#include <deque>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <algorithm>
#include <functional>
#include <cstring>
#include <utility>
#include <bitset>
#include <cmath>
#include <cstdlib>
#include <ctime>
#include <cstdio>
#include <climits>typedef unsigned long long ulol;
typedef long long lol;
typedef long int li;#define mp make_pair
#define F first
#define S second
#define sqr(a) ( (a) * (a) )
#define pb push_back
#define INF 999999999
#define ret(a) cout << endl; system("pause"); return(a)
//#define ret(a) return(a)using namespace std;int main()
{
lol n;
cin >> n;
vector<lol> ar(n);
for(int i = 0 ; i < n ; i ++)
cin >> ar[i];
for(int i = 0 ; i < n ; i += 3)
cout << i+1 << '-' << i+3 << ": " << ar[i]+ar[i+1]+ar[i+2] << endl;
ret(0);
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
sophiakrutko
08.04.2020 15:19
Введите, что будет выведено в результатевыполнения следующего фрагмента программы:a = 15;b:= 20;X:= b;if a b then x:= a-b else x := b-a;writeln (x);...
qweravq
08.04.2020 15:19
Каким свойством не обладает следующий алгоритм? Алгоритм Начало Взять наименьшее натуральное четное число Цикл пока результат не равен 1, выполнить {Возвести число в квадрат...
diniska3
08.04.2020 15:19
Напиши алгоритм создание призентации 3 класс...
mobilion2016
08.04.2020 15:17
Дан IP адрес, выбери и запиши верные ответы. IP адрес 188.38.109.181 компьютера относится к сети класса (какого?), адрес компьютера в сети (...) (...) (...), а (...) - это адрес...
Алена0607
25.12.2021 22:05
Кузнечик точка - 5 Флажки - 10,3,7,16,26...
Mazhie
20.06.2020 23:35
C++ Сформировать строку из 10 символов. На четных позициях должны находится четные цифры, на нечетных позициях – буквы....
АлёнаDances5943
20.06.2020 23:52
Напишите (на языке Pascal) программу, которая переставляет строки матрицы так, чтобы значения в столбце K шли в порядке убывания. Строки, у которых значения в столбце K равны,...
tematal
21.06.2020 23:55
Написать программу вычисления суммы трех чисел, используя процедуру вычисления суммы двух чисел.На паскале....
макашария
27.05.2020 11:49
Из пшеницы получается 77 % муки. Определи, сколько смололи пшеницы, если получили 6,16 т муки. Сколько муки получится из 2,4 т пшеницы?...
Strannik288
27.05.2020 11:49
РЕШИТЬ ПО СХЕМЕУчасток прямоугольной формы с четырьмя саженцами раздели на 4одинаковые части так, чтобы в каждую часть попал 1 саженец....
Популярные вопросы
|y|=9 |x|=1,6 |y|=5 дробь 9 |x+7|=10 |y-2|=5 |y-1,7|=4 23...
2
Какой объем сероводорода можно получить при взаимодействии соляной кислоты...
3
12. в одном из своих произведений в.в. набоков пишет: в нашелся в книжном...
1
Описание одного из природных или культурных памятников севера...
1
Составить уравнение. be(oh)2 + n2o5...
2
Вычислить: a)^3√0,343-^5√0,00243; б)^4√135 * ^4√375; в) (^-4√17^4)^-1; г)...
3
Вычислите формулу соединения в состав которых входят 3,95 мас.ч. элемента...
1
10 предложений с профессионализмами...
3
С1) перечислите все отрасли науки которыми занимался ломоносов 2) кто ещё...
2
На пружину сверху поместили груз массой 1 кг.насколько укоротилась пружина...
2
#include <sstream>
#include <fstream>
#include <string>
#include <vector>
#include <deque>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <algorithm>
#include <functional>
#include <cstring>
#include <utility>
#include <bitset>
#include <cmath>
#include <cstdlib>
#include <ctime>
#include <cstdio>
#include <climits>typedef unsigned long long ulol;
typedef long long lol;
typedef long int li;#define mp make_pair
#define F first
#define S second
#define sqr(a) ( (a) * (a) )
#define pb push_back
#define INF 999999999
#define ret(a) cout << endl; system("pause"); return(a)
//#define ret(a) return(a)using namespace std;int main()
{
lol n;
cin >> n;
vector<lol> ar(n);
for(int i = 0 ; i < n ; i ++)
cin >> ar[i];
for(int i = 0 ; i < n ; i += 3)
cout << i+1 << '-' << i+3 << ": " << ar[i]+ar[i+1]+ar[i+2] << endl;
ret(0);
}