tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
1. в одномерном массиве
1. в одномерном массиве а(10) вычислить среднее арифметическое квадратов положительных элементов.
Диана966666
1 21.09.2019 21:30
26
Ответы
McMamon
08.10.2020 08:00
PascalABC.NET 3.3.5, сборка 1644 от 23.03.2018
Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(10,-50,50); a.Println;
a.Where(x->x>0).Select(x->x*x).Average.Println
end.
Пример
29 45 -32 -44 -48 25 8 -4 -25 -22
888.75
ПОКАЗАТЬ ОТВЕТЫ
Эля54321
08.10.2020 08:00
Pascal ABC.
var
a: array [1..10] of integer; i,sum,k:integer;
begin
for i:= 1 to 10 do begin
a[i]:=random(100)-50;
if a[i]>0 then begin sum:=sum+sqr(a[i]); inc(k); end;
write(a[i], ' ');
end;
writeln;
writeln(sum/k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
ROUSWOOD
30.07.2019 10:30
Что означает знак =: в языке програмирования паскаль...
лев652
19.08.2019 22:20
Написать программу, определяющую (отвечающею на вопрос) - больше ли числа х сумма цифр введённого числа...
vladkanter
06.05.2020 12:18
Що входить до соціальних проектів? ...
sinelena2018
06.05.2020 12:18
Найдите значение переменной х по тексту: n:=56; х:=4; while n mod х 0 do х:=х+1; writeln(х):...
abduabdu2015
15.12.2020 22:19
Упростить выражение и схему,таблицу не надо...
polinabighui
09.04.2020 08:41
Какие экосистемы наиболее устойчивы в твоей местности? Объясни, чем это обусловлено Я живу в Нур-Султане (Казахстан...
6lackk
09.04.2020 08:41
Внешние очертания человека:А. Силуэт. Б. Профиль. В. Фигура. Г. Анфас....
Amina21777
09.04.2020 08:41
Белый медведь сначала км строго на юг, потом 4 км строго на восток, а далее 5 км строго на север. В итоге медведь оказался в том же самом месте, из которого начал свое путешествие....
nicita13254769p06wrf
09.04.2020 08:41
Приведите примеры природно-антропогенных ландшафтов...
madina20042004
09.04.2020 08:41
ЯКА ФОРМА поведінки на трьох прикладах...
Популярные вопросы
(8-тапсырма. Неологизм, термин, кәсіби сөздерді қолдана отырып, «Аста. мәдениет...
3
химия що таке вуглеводні та розв язати (* ̄(エ) ̄*)(* ̄(エ) ̄*)(* ̄(エ) ̄*)(* ̄(エ) ̄*)...
3
Укажите условия формирования селя Отсутствие доступа воды Наличие крутого склона...
3
Покажите чертежом процесс создания его изготовления поэтапно...
2
Решите значение функции и аргумента...
1
Всьавьте в пословицы необходимые наречия.Запишите понравшиеся пословицы...
1
Write a film review. Follow the tips for writing a film review....
1
В треугольнике SDE сторона SD = DE. точка Q принадлежит биссектрисе DP доказать,...
1
1. На примере круговорота воды в природе докажите, что круговорот – это непрерывно...
3
Напишите сочинение по тексту егэ. (1)В деле прогресса человечества мы редко...
1
Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(10,-50,50); a.Println;
a.Where(x->x>0).Select(x->x*x).Average.Println
end.
Пример
29 45 -32 -44 -48 25 8 -4 -25 -22
888.75
var
a: array [1..10] of integer; i,sum,k:integer;
begin
for i:= 1 to 10 do begin
a[i]:=random(100)-50;
if a[i]>0 then begin sum:=sum+sqr(a[i]); inc(k); end;
write(a[i], ' ');
end;
writeln;
writeln(sum/k);
end.