1. составьте программу в pascal abc. даны три числа. найти сумму двух наибольших из них. 2. составьте программу в pascal abc. для данного вещественного x найти значение следующей функции f, принимающей вещественные значения: f(x)=(2-х)/x2,если x> 0, иначе f(x)=6-х3 3. составьте программу в pascal abc. даны два числа. найти их сумму, разность и произведение.

dance7 dance7    2   02.09.2019 11:30    0

Ответы
leo1233121 leo1233121  06.10.2020 11:53
1 задача.
var a, b, c: integer;
begin
  write('Введите через пробел три числа: ');
  readln(a, b, c);
  if (a > b) then
    if (b > c) then
      write('Сумма двух наибольших чисел: ', a + b)
    else
      write('Сумма двух наибольших чисел: ', a + c)
  else
    if (c > a) then 
      write('Сумма двух наибольших чисел: ', c + b)
    else
      write('Сумма двух наибольших чисел: ', b + a)
end.

2 задача.
var x, f: real;
begin
  write('Введите значение x: ');
  readln(x);
  if (x > 0) then
    f := (2 - x) / (x * x)
  else
    f := 6 - (x * x * x);
  writeln('Значение функции при данном x: ', f)
end.

3 задача.
var a, b: integer;
  write('Введите через пробел два числа: ');
  readln(a, b);
  writeln('Сумма чисел: ', a + b);
  writeln('Разность чисел: ', a - b);
  writeln('Произведение чисел: ', a * b)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика