1. составьте программу, которая запрашивает с клавиатуры значения x и y. если x> y то печатается разность x-y, в противном случае y-x. 2. напишите программу, которая запрашивает с клавиатуры a, b, c. если a> b+c, то на печать выводится a. в другом случае выводится b+c. 3. напишите программу, которая запрашивает с клавиатуры значения k и x. если k=1, то вычисляется значение sin(x), если k=2, то вычисляется значение cos(x). 4. напишите программу, которая запрашивает значения p и m. если p> m2 , то печатается p, в противном случае m2. сделайте в паскале) и можете меня научить ?

Sovergon233 Sovergon233    2   12.09.2019 00:10    30

Ответы
Мурмик Мурмик  07.10.2020 08:33
//Pascal
//1)
var x, y: integer;
begin
write('Введите x y: ');
read(x, y);
if x > y then
writeln(x - y)
else
 writeln(y - x);
end.

//2)
var a, b, c: integer;
begin
write('Введите a b c: ');
read(a, b, c);
if (a > (b + c)) then
writeln(a)
else
writeln(b + c);
end.

//3)
var x, k: integer;
begin
write('Введите x k: ');
read(x, k);
if k = 1 then
writeln(sin(x))
else
if k = 2 then
writeln(cos(x))
else
writeln('k должен быть равен 1 или 2.');
end.

//4)
var p, m: integer;
begin
  write('Введите p, m: ');
  read(p, m);
  if p > m * 2 then
    writeln(p)
  else
    writeln(m * 2);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика