1.составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2.составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.

AннаКрутая AннаКрутая    1   04.07.2019 19:10    5

Ответы
Luska1367 Luska1367  28.07.2020 11:23
1)
var a: integer;
begin
    write('Введите число: ');
    read(a);
    if (a div 10 + a mod 10 + a div 10 mod 10) mod 2 = 0
    then writeln('Сумма цифр четна')                      
    else writeln('Сумма цифр нечетна')
end.
2)
var a: integer;
begin
    write('Введите число: ');
    read(a);
    if a mod 2 = 0 then writeln('Последняя цифра числа четная')
                           else writeln('Последняя цифра числа нечетная')
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика