1. составить программу вывода на экран всех трехзначных чисел, кратных 9. (паскаль, тремя составить программу вычисления суммы всех трехзначных чисел, кратных 17.(паскаль, тремя

kiss123kiss kiss123kiss    3   17.03.2019 14:30    34

Ответы
titsdeil titsdeil  25.05.2020 20:05

1)

Program Pr1;
uses crt;
var mas:array[100..999] of integer;
i:integer;
Begin
clrscr;
for i:=100 to 999 do mas[i]:=i; {1 sposob}
for i:=100 to 999 do if mas[i] mod 9 =0 then writeln(mas[i]);
i:=100; {2 sposob}
while i<=999 do begin
if mas[i] mod 9=0 then writeln(mas[i]);
i:=i+1;
end;
i:=100; {3 sposob}
repeat
if mas[i] mod 9=0 then writeln(mas[i]);
i:=i+1
until i=999
end.

2)

Program Pr1;
uses crt;
var mas:array[100..999] of integer;
i,v:integer;
Begin
clrscr;
v:=0;
for i:=100 to 999 do mas[i]:=i; {1 sposob}
for i:=100 to 999 do if mas[i] mod 17 =0 then v:=v+mas[i];
writeln(v);
i:=100; {2 sposob}
v:=0;
while i<=999 do begin
if mas[i] mod 17=0 then v:=v+mas[i];;
i:=i+1;
end;
writeln(v);
i:=100; {3 sposob}
v:=0;
repeat
if mas[i] mod 17=0 then v:=v+mas[i];
i:=i+1
until i=999;
writeln(v);
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика