1. составить программу, которая формирует массив из 15 случайных чисел от -20 до 20 и четные числа возводит в квадрат. на экран выводятся исходные данные и преобразованные значения через 4 пробела. 2. составить программу, которая формирует массив из 10 целых чисел, элементы массива вводятся вручную с клавиатуры. поменять местами первый и последний элементы массива и вывести на экран.

rmshturkop01n73 rmshturkop01n73    2   12.09.2019 05:10    0

Ответы
ArT003 ArT003  07.10.2020 08:59
1.
Program arrays;
const n = 15;
Var a:array [1..n] of integer;
    i:integer;
begin
  for i:=1 to n do a[i]:= random(-20, 20);
  for i:=1 to n do
  begin
    if a[i] mod 2 = 0 then
      a[i]:=sqr(a[i]);
  end;
  for i:= 1 to n do write(a[i], ' ');
end.
2.
Program arrayss;
const n = 10;
Var a:array [1..n] of integer;
    i:integer;
begin
  for i:=1 to n do read(a[i]);
  swap(a[1], a[10]);
  for i:= 1 to n do write(a[i], ' ');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика