1.определите значение, которое выведет программа:

s: =1;

for z: =1 to 8 do a[z]: =sqr(z);

for k: =1 to 8 do

if a[k]> 9 then a[k]: =2;

for z: =4 to 8 do s: =s*a[k];

write(s);
2.что вычисляет данный алгоритм?

var z: integer; a: array[1..8] of integer;

begin

s: =0;

for z: =1 to 8 do s: =sqr(z);

end.

выберите один ответ:
a. формирует массив а, каждый элемент которого равен квадрату z
b. формирует массив а, каждый элемент которого равен квадрату своего индекса
c. находит квадрат последнего значения переменной цикла
d. находит корни квадратные из переменной цикла и сохраняет в массив
e. находит сумму квадратов индексов
f. формирует массив а, каждый элемент которого равен 4

3. назовите конструкцию:

d: =15; a: =0; z: =2;

while a
begin

a: =a+z; write(a)

end;

выберите один ответ:
a. полное ветвление
b. выбор
c. неполное ветвление
d. составной оператор
e. цикл "повтори n раз"
f. цикл "пока" с предусловием
g. цикл "пока" с постусловием
h. следование
i. неполное ветвление

12233454647758886776 12233454647758886776    1   03.12.2019 21:06    0

Ответы
Tima66666666 Tima66666666  17.08.2020 14:13

1)S=1*2*2*2*2*2=32

2)c

3)f

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика