1)напишите программу, которая считает количество четных цифр введенного числа 2) напишите программу, которая вводит с клавиатуры натуральное число n и определяет его факториал, т.е. произведение натуральных чисел от 1 до n: n! =1×2×3××n. что будет, если ввести большое значение n (например, 20)? 3) напишите программу, которая вводит натуральные числа a и n и вычисляет a^n.

arsenijcurikov arsenijcurikov    1   08.06.2019 19:10    3

Ответы
olyacolesnik20 olyacolesnik20  07.07.2020 20:42
1)
var
  a, b: integer;

begin
  readln(a);
  foreach e: char in a.ToString() do //Проходит по каждому символу в строке, полученной путём преобразования числа
    if (Byte.Parse(e) mod 2 = 0) then
      inc(b); //Увеличивает значение на 1
  writeln(b);
end.
2 в файле
3)
var
  a, n: integer;

begin
  readln(a, n);
  writeln(power(a, n)); //power возводит число в указанную степень
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика