1) напишите программу, которая считает количество чётных цифр введённого числа. 2) напишите программу, которая считает сумму цифр введённого числа. все для c++ хорошо если через цикл с условиями
#include <iostream> using namespace std; int main() { int val = 253; int sum = 0; int tmp = 0; int c = 0; while (val) { tmp = val % 10; if (!(tmp % 2)) { ++c; } sum += tmp; val /= 10; } cout << "Res = " << sum << endl; cout << "Count = " << c << endl; system("pause"); return 0; }
using namespace std;
int main()
{
int val = 253;
int sum = 0;
int tmp = 0;
int c = 0;
while (val) {
tmp = val % 10;
if (!(tmp % 2)) {
++c;
}
sum += tmp;
val /= 10;
}
cout << "Res = " << sum << endl;
cout << "Count = " << c << endl;
system("pause");
return 0;
}