1) напишите программу, которая организует массив из 10 целых чисел по случайному закону в интервале от 0 до 200. и определяет сумму элементов массива кратных 5. на экран выводятся элементы созданного массива в строку с форматом 4, элементы , значение которых кратно 5 и сумма. используйте 2 цикла.

helpme177 helpme177    3   14.11.2019 10:11    1

Ответы
angelocheck15 angelocheck15  10.10.2020 13:18

var

 a: array [1..10] of Integer;

 i, s: Integer;

begin

 Randomize;

 s := 0;

 for i := Low (a) to High (a) do begin

   a [i] := Random (201);

   Write (a [i] :4);

 end;

 WriteLn;

 for i := Low (a) to High (a) do begin

   if a [i] mod 5 = 0 then begin

     s := s + a [i];

     Write (a [i] :4);

   end;

 end;

 WriteLn;

 WriteLn ('Сумма = ', s);

 ReadLn;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика