1. напишите программу для создания трех массивов каждый их 8 элементов a b и c
2.заполните массив а с клавиатуры
3. заполните массив в квадратами номеров соответствующих элементов
4.заполните массив с случайными числами
5.выведите эти три массива на экран расположив их элементы в строку

Ilya0902 Ilya0902    2   22.12.2019 12:33    3

Ответы
pzuzuk pzuzuk  10.10.2020 22:23

var

a, b, c: array[1..8] of integer;

i: integer;

begin

for i := 1 to 8 do

read(a[i]);

for i := 1 to 8 do

b[i] := sqr(a[i]);

for i := 1 to 8 do

c[i] := random(10000);

for i := 1 to 8 do

write(a[i], ' ');

writeln();

for i := 1 to 8 do

write(b[i], ' ');

writeln();

for i := 1 to 8 do

write(c[i], ' ');

writeln();

end.

ПОКАЗАТЬ ОТВЕТЫ
Алтын12938849к9ку9 Алтын12938849к9ку9  10.10.2020 22:23

PascalABC.NET

begin

 var a := ReadArrInteger(8);

 var b := ArrGen(8, i -> i * i, 1);

 var c := ArrRandom(8, -99, 99);

 a.Println;

 b.Println;

 c.Println

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика