1)написать программу нахождения суммы квадратов чисел от 5 до 25 2) дан массив а, состоящий из 15 целых чисел. заполнен с клавиатуры. найти произведение элементов массива, больших 5. паскаль

elenarum18 elenarum18    1   27.08.2019 21:50    0

Ответы
зубрильчик зубрильчик  05.10.2020 23:30
//PascalABC.NET версия 3.2, сборка 1389
//Если программа не запускается, то обновите версию
begin
    Writeln('суммa квадратов чисел от 5 до 25 =', Range(5, 25).Select(x -> x * x).Sum);
    writeln;
    
    var a := ArrGen(15, i -> ReadInteger('a[' + i.toString() + ']='), 1);
    writeln('произведение элементов массива, больших 5 =', a.Where(x -> x > 5).Aggregate(1, (x, y)-> x * y));
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика