1. Написать программу. Дано трехзначное число, определить является ли сумма его цифр кратна числу х (х - любое число, которое введет пользователь). Пример:
введите трехзначное число: 345
Введите любое целое число: 6
Сумма цифр числа 345 кратна числу 6 (python)
!

luya21 luya21    1   19.12.2021 18:20    5

Ответы
JimmyN JimmyN  19.12.2021 18:30

ЕСЛИ ПРОГРАММА НЕ РАБОТАЕТ - СМОТРИ ФОТО

a = 345 # это число можно менять, если надо, чтобы пользователь его вводил, напишите вместо числа int(input())

x = int(input())

a = str(a)

sum = 0

for j in a:

   sum += int(j)

if sum % x == 0:

   print('КРАТНО')

else:

   print('НЕ КРАТНО')


1. Написать программу. Дано трехзначное число, определить является ли сумма его цифр кратна числу х
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика