1. дан целочисленный массив из 30 элементов, которые могут принимать значения от 150 до 200 – рост учащихся выпускного класса. в баскетбольную команду берут тех, чей рост не менее 180 см. напишите программу, которая подсчитывает число претендентов в состав баскетбольной команды и выводит номера подходящих кандидатур.
Program Zn;
var m:array[1..30] of byte;
c,i:integer;
Begin
for i:=1 to 30 do begin
writeln('Введите рост кандидата');
Readln(m[i]);
if m[i]>=180 then inc(c)
end;
writeln('Количество подходящих кандидатур: ',c);
end.
(Программа проверена и откомпелирована на Pascal.NET, если есть вопросы, пишите)
const
n = 30;
var
a:array[1..n] of byte;
i, count:integer;
begin
randomize;
for i := 1 to n do
begin
a[i] := random(51) + 150;
writeln('Рост претендета № ', i:2, ' - ', a[i]);
end;
write('Номера подходящих кандидатур: ');
for i := 1 to n do
if a[i] >= 180 then
begin
inc(count);
write(i, ' ');
end;
writeln;
writeln('Общее количество подходящих претендентов: ', count);
end.